Commit 1a12214a authored by Jeremie Knuesel's avatar Jeremie Knuesel

Bump GTK+ to 3.22

parent f6dd3682
......@@ -5,7 +5,7 @@ girara user interface library and several document libraries.
Requirements
------------
gtk3 (>= 3.10)
gtk3 (>= 3.22)
glib (>= 2.50)
girara (>= 0.2.8)
sqlite3 (optional, >= 3.5.9)
......
......@@ -26,7 +26,7 @@ GLIB_MIN_VERSION = 2.50
GLIB_PKG_CONFIG_NAME = glib-2.0
# GTK
GTK_VERSION_CHECK ?= 1
GTK_MIN_VERSION = 3.10
GTK_MIN_VERSION = 3.22
GTK_PKG_CONFIG_NAME = gtk+-3.0
# pkg-config binary
......
......@@ -157,7 +157,6 @@ zathura_update_view_ppi(zathura_t* zathura)
double ppi = 0.0;
#if GTK_CHECK_VERSION(3,22,0)
GdkMonitor* monitor = gdk_display_get_monitor_at_window(display, window);
if (monitor == NULL) {
return;
......@@ -194,7 +193,6 @@ zathura_update_view_ppi(zathura_t* zathura)
#endif
girara_debug("monitor width: %d mm, pixels: %d, ppi: %f", width_mm, monitor_geom.width, ppi);
#endif
zathura_document_set_viewport_ppi(zathura->document, ppi);
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment