Commit edc5a8bd authored by Sebastian Ramacher's avatar Sebastian Ramacher

Explicitly handle pango dependency

parent 7c5802fb
...@@ -16,6 +16,7 @@ ...@@ -16,6 +16,7 @@
#include "utils.h" #include "utils.h"
#include <glib/gi18n-lib.h> #include <glib/gi18n-lib.h>
#include <pango/pango-font.h>
#include <stdlib.h> #include <stdlib.h>
#ifdef WITH_LIBNOTIFY #ifdef WITH_LIBNOTIFY
......
...@@ -33,8 +33,9 @@ localedir = get_option('localedir') ...@@ -33,8 +33,9 @@ localedir = get_option('localedir')
libm = cc.find_library('libm', required: false) libm = cc.find_library('libm', required: false)
glib = dependency('glib-2.0', version: '>=2.50') glib = dependency('glib-2.0', version: '>=2.50')
gtk3 = dependency('gtk+-3.0', version: '>=3.20') gtk3 = dependency('gtk+-3.0', version: '>=3.20')
pango = dependency('pango', version: '>=1.14')
build_dependencies = [libm, glib, gtk3] build_dependencies = [libm, glib, gtk3, pango]
pc_requires = ['glib-2.0', 'gtk+-3.0'] pc_requires = ['glib-2.0', 'gtk+-3.0']
# defines # defines
...@@ -56,7 +57,7 @@ flags = [ ...@@ -56,7 +57,7 @@ flags = [
flags = cc.get_supported_arguments(flags) flags = cc.get_supported_arguments(flags)
# optional dependencies # optional dependencies
pc_requires_private = [] pc_requires_private = ['pango']
libnotify = dependency('libnotify', version: '>=0.7.0', required: false) libnotify = dependency('libnotify', version: '>=0.7.0', required: false)
jsonc = dependency('json-c', required: false) jsonc = dependency('json-c', required: false)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment