Commit d7b06ca3 authored by Sebastian Ramacher's avatar Sebastian Ramacher

Require GTK+ 3.6

Signed-off-by: Sebastian Ramacher's avatarSebastian Ramacher <sebastian+dev@ramacher.at>
parent ff976d48
......@@ -26,7 +26,7 @@ GLIB_MIN_VERSION = 2.32
GLIB_PKG_CONFIG_NAME = glib-2.0
# GTK
GTK_VERSION_CHECK ?= 1
GTK_MIN_VERSION = 3.0
GTK_MIN_VERSION = 3.6
GTK_PKG_CONFIG_NAME = gtk+-3.0
# pkg-config binary
......
......@@ -28,9 +28,6 @@ main(int argc, char* argv[])
textdomain(GETTEXT_PACKAGE);
/* init gtk */
#if !GTK_CHECK_VERSION(3, 6, 0)
gdk_threads_init();
#endif
gtk_init(&argc, &argv);
/* parse command line arguments */
......@@ -282,13 +279,7 @@ main(int argc, char* argv[])
}
/* run zathura */
#if !GTK_CHECK_VERSION(3, 6, 0)
gdk_threads_enter();
#endif
gtk_main();
#if !GTK_CHECK_VERSION(3, 6, 0)
gdk_threads_leave();
#endif
/* free zathura */
zathura_free(zathura);
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment